え?ブログが開かない!? WordPressのプラグインがエラーになった場合の対処法

wp-appbox-icon
当ブログは「WP-Appbox」というWordPress向けプラグインを使ってるんだけどさ。

スポンサーリンク

プラグインを更新したらブログが見られん…


このWP-Appboxがバージョン3.3.0にアップデートされたので、WordPressの管理画面から更新したところ、見たことのないエラー画面が表示され、オレのブログが見られないw

エラーの内容はsyntax error。つまり文法的エラーだよと。wp-appbox.phpというスクリプトの316行目が怪しいぞと。

サーバーにログインし、プラグインの名前を変更したら…


スクリプトの316行目が怪しそうと言われても、オレはプラグインの作者じゃないし、よく分からんww

それよりもブログが見られないと困るので、この場をどう乗り切るかしか頭にない。

ブログのトップページが開かないということで、すでにWordPressの管理画面にも辿り着けない状態に陥ってる。

仕方がなくレンタルサーバーにログインし、エラーの元凶となってるファイルの名前を変更してみた。ちなみに、プラグインのフォルダー名を変更してもいいみたいなんだけど、オレはやり方がよく分からず、ファイル名の変更に逃げた次第ww

ファイル名は何でも構わないんだけど、とりあえず「wp-appbox-old.php」にしといた。

とりあえずブログは見られるようになるも…


再度ブログのトップページを開いてみると、今度はいつものようにちゃんと表示できた。プラグインの管理画面にはWP-Appboxは停止中的な文言が表示されてるけど、ひとまずはオケ。

ところが、WP-Appboxが復活しないと、当ブログに貼ってあるアプリへのリンクは全部こんなふうに間抜けな感じになっちゃうんだよね。これじゃぁ一体全体何のアプリか分からない。

WP-Appboxの作者さんに連絡しなくちゃ。

PHPのバージョンが低すぎてダメ!?

問い合わせから約8時間後。WP-Appboxの作者であるmarcelさんから返信があった。

えーと?

Please check your PHP version, WP-Appbox needs PHP 5.3+.

つまり、

WP-AppboxはPHP 5.3以上が必要なんだよ。

ってことか!

よく見てみたら、WP-Appboxのページにサラッと書いてあるし…。グググ。

ラクサバはPHP 5.3に一部対応済み

で、今度はオレがサーバーをレンタルしてる「ラクサバ」の仕様を確認してみる。

すると、

ラクサバのPHPバージョン

PHP 5.2.17

詰んだ\(^o^)/

まぁダメ元でラクサバに今後の対応予定を訊いてみるけど、あまり期待はできないだろうなー。

3日後。ラクサバから返信が来た。結構待ったよ。

ラクサバからの回答

今週中には、PHPのバージョンを選択いただけるように準備しておりますので、今しばらくお待ちください。

ラクサバから返信が来たのは2016年6月20日(月)。なので「今週中」ということは、一般常識的には6月25日(土)までには、PHPのバージョンが5.3になるはずだな。よかったー。

さらにそれから3日後。2016年6月23日(木)にラクサバの「サーバーパネル」→「サーバー情報」を確認してみたところ、いつの間にかPHPのバージョンが5.3.29に変更されてた!

他のレンタルサーバーの事情はよく分からないけど、ラクサバの場合は、どうやらPHP 5.3への対応は全サーバーまとめてやるのではなく、収容サーバーごとに少しずつ行なってる模様。まだPHP 5.3になってない場合は、一度ラクサバに問い合わせ、自分のサーバーがいつ頃PHP 5.3に対応するかの予定を確認してみるといいかもしれないね。

格安レンタルサーバーには訳がある

実は、ここんとこ立て続けにPHPのバージョンがショボイことがネックな事件が続発してまして。

当ブログがお世話になってるWordPress向けテーマ「Simplicity」の最新バージョン2も、PHP 5.3以上が必要なので、いつまでも乗り換えられずにいたんだよね。

WP-Appboxの件がようやく解決したので、次はSimplicity2への乗り換えを検討しなくちゃな。

というか、サーバーをレンタルする際は、PHPのバージョンにもこだわった方がいいんだな。

安さに負けてスペックを疎かにすると、本当に使いたいWordPressのプラグインとかテーマなんかを使えなくなるよ。

…って当たり前か。

スポンサーリンク

気になる記事はシェア!あとでじっくり読む!

お好きなブログリーダーで購読できます!

コメント

  1. say より:

    初めまして。
    私のwordpressブログでもWP-Appboxを使用していたのですが、こちらと同じように突然使えなくなりました。
    困り果てたものの知識がないので放置(笑)していたのですが、こちらで拝見したPHPバージョンについて確認したところ、PHP5.2となっていました。最新版に変更することでWP-Appboxも動作するようになり、本当に助かりました!!
    ありがとうございましたm(_ _)m

    • yashimac より:

      sayさん

      コメントありがとう!

      放置(?)していたブログが復活したとのことで、よかったですね。

      この程度のことで少しでもお役に立てたのであれば、私も嬉しいです。

      何かトラブッたらまたググってみて下さい。そのときもこのブログがヒットしますように(^^)v