Movable Type 3.3でうぬぬ?

じつはさっき、Movable Type 3.2から3.3にアップグレードをした。
FTPでmtフォルダーに上書きコピーしたあと、mt.cgiを実行したら、


こんな警告が出た。

Movable Typeのアップグレード
インストールされているPerlのバージョン(5.00503)はサポートされている最低バージョン(5.6.1)よりも低いものです。While Movable Type may run, it is an untested and unsupported environment. We strongly recommend upgrading to at least Perl 5.6.1.警告を無視してアップグレードを続行しますか?

「はい」と答えたらアップグレードは終了した。
かに診えた。
で、そそくさと記事を投稿しよーとしたら、今度はこんなエラーが発生!

Can’t use string (“MT::Log::Entry::”) as a symbol ref while “strict refs” in use at lib/MT/Log.pm line 95.

Log.pmファイルの95ラインめを診るも、原因なんて分かるワケなし。
やっぱサーバー側のPerlのバージョンが古いせいなのかナ。
ワケわからんけど、ホスティングやってるとこに相談してみっか。
ゴミ箱に入れてあったMovable Type 3.2を3.3に上書きコピーして、かろうじてダウングレード(?)成功。
今に至る。

コメント

タイトルとURLをコピーしました